XCOM: Enemy Unknown - Elite Soldier Pack
Release Date: 8 Oct, 2012
icon icon
33
icon icon
0
Out of stock
Steam
category
systems
RRP: $4.99
Our price: $1.35
or 1350 points

Out of stock

add to wishlist
Customize your squad with three new  bonus items. Instantly unlock a new recruit in your barracks inspired by the original X-COM: UFO Defense. Outfit your soldiers with specialized armor upgrades including the new Hyperion and Reaper soldier armor kits. Customize your soldiers’ appearances with a variety of colors and tints for all armor sets.

Note: The Elite Soldier Pack was included in the pre-purchase offer of XCOM: Enemy Unknown.


SYSTEM REQUIREMENTS

Windows
Minimum:
  • OS:Windows Vista
  • Processor:2 GHz Dual Core
  • Memory:2 GB RAM
  • Graphics:NVIDIA GeForce 8600 GT / ATI Radeon HD 2600 XT or greater
  • DirectX®:9.0
  • Hard Drive:20 GB HD space
  • Sound:DirectX Compatible
  • Other Requirements:Broadband Internet connection
  • Additional:Initial installation requires one-time internet connection for Steam authentication; software installations required (included with the game) include Steam Client, Visual C++ 2008 Redistributable, DirectX and Microsoft .NET 4.
Recommended:
  • OS:Windows 7
  • Processor:2 GHz Dual Core (Intel Core 2 Duo 2.4 GHz or Athlon X2 2.7 GHz)
  • Memory:4 GB RAM
  • Graphics:NVIDIA GeForce 9000 series / ATI Radeon HD 3000 series or greater
  • DirectX®:9.0
  • Hard Drive:20 GB HD space
  • Sound:DirectX Compatible
  • Other Requirements:Broadband Internet connection
  • Additional:Initial installation requires one-time internet connection for Steam authentication; software installations required (included with the game) include Steam Client, Visual C++ 2008 Redistributable, DirectX and Microsoft .NET 4.
Mac OS X
Minimum:
  • OS: 10.7.5 (Lion)
  • Processor: 2.0 GHz Intel Core 2 Duo (Dual-Core)
  • Memory: 4 GB RAM
  • Hard Disk Space: 20 GB
  • Video Memory: 256 MB
  • Video Card: ATI Radeon HD 2600 / NVidia Geforce 8800
  • Additional: Broadband Internet Connection.
  • NOTICE:The following graphics cards are not supported: ATI X1xxx series, ATI HD2xxx series, Intel GMA series, NVIDIA 7xxx series, NVIDIA 8xxx series. The following cards require you to have 8GB of system RAM: NVIDIA 320M, NVIDIA 9400 and Intel HD3000.
Recommended:
  • OS: 10.8.4 (Lion)
  • Processor: 2.4 GHz Intel Core 2 Duo (Dual-Core)
  • Memory: 8 GB RAM
  • Hard Disk Space: 20 GB
  • Video Memory: 1GB
  • Additional: Broadband Internet Connection.
  • NOTICE:The following graphics cards are not supported: ATI X1xxx series, ATI HD2xxx series, Intel GMA series, NVIDIA 7xxx series, NVIDIA 8xxx series. The following cards require you to have 8GB of system RAM: NVIDIA 320M, NVIDIA 9400 and Intel HD3000.
SteamOS + Linux
Minimum:
  • OS: Ubuntu 14.04 (64 bit)
  • Processor: 2GHz
  • Memory: 4GB Memory
  • Graphics: 512MB*
  • Hard Drive:16GB HD space
  • Other Requirements: Nvidia 600 series+, AMD 6000 series+, Intel Iris Pro
 Recommended:
  • OS: Ubuntu 14.04 (64 bit)
  • Processor: 3 GHz
  • Memory: 8GB Memory
  • Graphics: 1GB*
  • Hard Drive: 16GB HD space
  • Other Requirements: Nvidia 700 series+, AMD 6000 series+

There are currently no reviews for this product.
Why don't you login and be the first to share your thoughts!

Login Register