Metro: Last Light
Release Date: 14 May, 2013
icon icon
4211
icon icon
1
3 in stock
Steam
category
systems
RRP: $24.99
Our price: $9.64

It is the year 2034. Beneath the ruins of post-apocalyptic Moscow, in the tunnels of the Metro, the remnants of mankind are besieged by deadly threats from outside – and within. Mutants stalk the catacombs beneath the desolate surface, and hunt amidst the poisoned skies above.

But rather than stand united, the station-cities of the Metro are locked in a struggle for the ultimate power, a doomsday device from the military vaults of D6. A civil war is stirring that could wipe humanity from the face of the earth forever. As Artyom, burdened by guilt but driven by hope, you hold the key to our survival – the last light in our darkest hour…

System Requirements

Windows
  • MINIMUM:
    • OS: Windows Vista, 7 or 8 (64-bit only)
    • Processor: Dual Core CPU (2.2+ GHz Dual Core CPU or better)
    • Memory: 2 GB RAM
    • Graphics: DirectX 10, Shader Model 4 compliant graphics cards (GeForce 8800 GT 512 MB, GeForce GTS 250, etc)
    • DirectX: Version 10
    • Hard Drive: 10 GB available space
    • Additional Notes: 64-bit only
  • RECOMMENDED:
    • OS: Windows 7 or 8 (64-bit only)
    • Processor: Any Quad Core or 3.0+ GHz Dual Core CPU
    • Memory: 4 GB RAM
    • Graphics: DirectX 11 compliant graphics card (GeForce GTX 480 and above)
    • DirectX: Version 11
    • Hard Drive: 10 GB available space
    • Additional Notes: (64-bit only)
Mac OS X
  • MINIMUM:
    • OS: OS X 10.9.5 Mavericks or newer
    • Processor: 3.2 GHz Intel Core i5
    • Memory: 8 GB RAM
    • Graphics: Radeon HD7950 3GB
    • Additional Notes: Due to performance issues across a range of hardware, support for Nvidia graphics cards has been temporarily suspended.
  • RECOMMENDED:
    • OS: OS X 10.9.5 Mavericks or newer
    • Processor: 3.2 GHz Intel Core i5
    • Memory: 8 GB RAM
    • Graphics: Radeon HD7950 3GB
    • Additional Notes: Due to performance issues across a range of hardware, support for Nvidia graphics cards has been temporarily suspended.
SteamOS + Linux
  • MINIMUM:
    • OS: 64-bit Ubuntu 12.04 or 14.04 or Steam OS
    • Processor: Intel Core i5 2.7 GHz (or equivalent AMD)
    • Memory: 4 GB RAM
    • Graphics: NVIDIA Geforce 460 / AMD 5850 with 2GB VRAM
    • Hard Drive: 10 GB available space
    • Additional Notes: Due to OpenGL 4, Intel video cards no longer supported
  • RECOMMENDED:
    • OS: 64-bit Ubuntu 12.04 or 14.04 or Steam OS
    • Processor: Intel Core i7 2.5 Ghz (or equivalent AMD)
    • Memory: 8 GB RAM
    • Graphics: NVIDIA Geforce 680 / AMD 7870 with 2GB VRAM+
    • Hard Drive: 10 GB available space
    • Additional Notes: Due to OpenGL 4, Intel video cards no longer supported

There are currently no reviews for this product.
Why don't you login and be the first to share your thoughts!

Login Register